PyScripter y Anaconda3

Posted by in Python

Tras mucho tiempo sin escribir nada de Python, vuelvo a tocar este tema. Concretamente, el IDE PyScripter y Anaconda3, la distribución de Python.

Recientemente, he vuelto a trabajar con este IDE que siempre me ha gustado tras mucho tiempo sin hacerlo, pero desde que tengo Anaconda3 con las últimas versiones de Python 3.7, recibía este mensaje an iniciar PyScripter:

Para solventar el asunto, he tendo que buscar varias pistas, si bien en las propias FAQ de PyScripter adelanta el asunto.

Resuelto con un archivo .bat

Tal y cómo pone en las FAQ, la solución es crear un pequeño script guardado en un archivo .bat para solventar la situación. En mi caso, he creado este script tan simple en el propio directorio donde tengo instalado PyScripter:

El directorio donde tengo PyScripter, ahora está así:

Al ejecutar el archivo .bat, ya no tengo el mensaje primero, y felizmente, dispongo de Python 3.7.1 disponible:

Si accedes a las versiones disponibles, tenemos registrado Python 3.7:

Gracias a este pequeño script, ya no será necesario que vuelvas a ejecutar el archivo .bat, porque se ha quedado registrado Python.

PyScripter 3.6

Afortunadamente, PyScripter ha evolucionado desde la primera versión de la que se habló en este blog, la 2.6, allá por 2013, y ahora tienes disponibles varios temas, y lo más importante, ser capaz de trabajar con las últimas versiones de Python porque con Python 2, siempre ha funcionado de maravilla.

Pues nada, a programar se ha dicho!!